HOW TO DISABLE XFCE4 AT BOOT TIME IN UBUNTU 14.04

Got any great tips or tricks you're dying to share with the rest of the world? Then please post them here.
They don't have to be specifically related to building a media server but please do try to keep them suitably "geeky".
User avatar
Shag
Member
Member
Posts: 9
Joined: April 25th, 2014, 4:49 pm

HOW TO DISABLE XFCE4 AT BOOT TIME IN UBUNTU 14.04

Postby Shag » July 1st, 2014, 3:50 pm

I have tried multiple ways of preventing xfce4 from loading at server start and the only successful option that I have implemented was to edit the grub file.

Edit /etc/default/grub

Code: Select all

 sudo vim /etc/default/grub


Find this line in your grub file
GRUB_CMDLINE_LINUX_DEFAULT=””

no matter what is in the quotes change it to "text" so it looks like this
GRUB_CMDLINE_LINUX_DEFAULT=”text”

Update Grub:

Code: Select all

sudo update-grub

This will bring you to a txt login when your server reboots or starts.

If you want to run xfce4 after you log in type

Code: Select all

startxfce4



.

Return to “Tips 'n' Tricks”

cron