Setting up VNC

Discussion and Technical Support for general software applications and utilities including OS related issues.
iain1234
Member
Member
Posts: 3
Joined: April 20th, 2014, 8:37 am

Setting up VNC

Postby iain1234 » April 20th, 2014, 8:41 am

Hello, I am following your guide but am stuck in a dead end.

I worked right through from start to setting up VNC - which doesn't apear to be working for me.

I installed 14.04LTS, got putty fine, and even installed gnome. Started the vnc service , then closed it. Then went to vim to edit the file how I should have (see below) However - when I restart VNC and then use the Tight VNC client on Windows 8.1 (update 1) - I get a grey screen that has 3 check boxes in the top left corner (Accept Clipboard from viewers... etc)

There is nothing I can interact with, no desktop. Just a grey screen. :S

What should I do now?

#!/bin/sh

# Uncomment the following two lines for normal desktop:
unset SESSION_MANAGER
#exec /etc/X11/xinit/xinitrc
gnome-session --session=gnome-classic &

[ -x /etc/vnc/xstartup ] && exec /etc/vnc/xstartup
[ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources
xsetroot -solid grey
vncconfig -iconic &
#x-terminal-emulator -geometry 1280x1024+10+10 -ls -title "$VNCDESKTOP Desktop" &
#x-window-manager &

User avatar
Ian
Moderator
Posts: 751
Joined: January 1st, 2011, 8:00 am

Re: Setting up VNC

Postby Ian » April 20th, 2014, 6:35 pm

Hi there and welcome to the forums :thumbup:

I'm afraid you've not done anything wrong, VNC seems to be broken currently. :-( I'm hitting the same issue now on 14.04LTS too. As and when I get it working (or give up trying) I'll update the site.

Sorry :oops:

Ian.

iain1234
Member
Member
Posts: 3
Joined: April 20th, 2014, 8:37 am

Re: Setting up VNC

Postby iain1234 » April 21st, 2014, 6:46 pm

ah thanks for the reply - I thought I was going crazy! Going round in circles over and over.

mnrbig
Member
Member
Posts: 1
Joined: April 23rd, 2014, 2:22 pm

Re: Setting up VNC

Postby mnrbig » April 23rd, 2014, 2:24 pm

I added

gnome-panel &
gnome-settings-daemon &
metacity &
nautilus -n &
gnome-terminal &


as per ttps://medium.com/linux-operation-system/5e6fac849ea3

to the file and mine works now.

wsimm
Member
Member
Posts: 7
Joined: October 31st, 2011, 2:15 am

Re: Setting up VNC

Postby wsimm » April 30th, 2014, 11:28 am

Also, when I reboot the system, it now comes in graphical mode instead of the command line. Is this normal. Did not do this in 10.04, which is the release I am on at the moment.

wsimm
Member
Member
Posts: 7
Joined: October 31st, 2011, 2:15 am

Re: Setting up VNC

Postby wsimm » April 30th, 2014, 11:37 am

Never mind - I did not read far enough down the page to see how to stop the graphical interface startup.

User avatar
Shag
Member
Member
Posts: 9
Joined: April 25th, 2014, 4:49 pm

Re: Setting up VNC

Postby Shag » May 5th, 2014, 2:49 pm

Morning,
I was really happy to find your guide for the current version of linux but I also have the same issue as iain1234. From what I have read gnome-fallback.desktop now requires accelerated graphics, or is broken, and defaults to gnome3 somehow. So if there no fix in the near future, I have seen some installing xfce4 with no issues.

I am very much a newbie to linux, thats why I was happy to find your complete guide. My question is, if I want a graphical interface with VNC now, how do I uninstall gnome? Then install xfce4. It seemed to have installed many dependencies. Or if you have it working what other tips may I try to get mine working. I've tried mnrbig solution but didn't work for me.

Thanks for all your work on this site.

Shag

User avatar
Ian
Moderator
Posts: 751
Joined: January 1st, 2011, 8:00 am

Re: Setting up VNC

Postby Ian » May 5th, 2014, 3:51 pm

Hi there and welcome to the forums :thumbup:

I agree with you about gnome having many dependencies. I think if you purge gnome you'd end up breaking something else. So, unless you want to wipe the OS and start over the easiest thing to do is just leave it asis. You can disable it from actually starting by editing the gdm.conf file as shown at the bottom of this page.

Ian.

zulu
Member
Member
Posts: 6
Joined: May 6th, 2014, 5:25 pm

Re: Setting up VNC

Postby zulu » May 6th, 2014, 5:49 pm

I was following the VNC install guide and got stuck like you guys with the grey screen. The above solution only showed to me a grey screen with black terminal window in the middle. I'm running ubuntu server 14.04!!!

maddyn99
Member
Member
Posts: 2
Joined: May 12th, 2014, 6:43 pm

Re: Setting up VNC

Postby maddyn99 » May 12th, 2014, 6:48 pm

I am stuck on this part

Next, download and install TightVNC onto your desktop computer. When you launch it type the "X Desktop name" in the VNCServer box. See the DOS-type screenshot above for the name of your "X Desktop name". So, in my case I'd type MyMediaServer:1 in the VNC Server Listbox. See below.

There is no DOS screen shot there ...that I can see. So where do I get the X Desktop name?


Return to “Software - Applications and Operating Systems”

cron