NFS - unable to mount Directory on NFS Client

Discussion and Technical Support for general software applications and utilities including OS related issues.
wsimm
Member
Member
Posts: 7
Joined: October 31st, 2011, 2:15 am

NFS - unable to mount Directory on NFS Client

Postby wsimm » March 20th, 2013, 12:57 pm

I have three virtual Ubuntu 10.4 servers running. One is the KVM host and the other two are Guests. All machines are working properly and all the data is on the KVM host.

I use one of the guests as the Mediaserver and the other as an Apache server. I have successfully exported my media directories from the Host to the Mediaserver using NFS via Webmin (I have specified the IP address of the Guest rather than sending to all addresses). That all works fine and it mounts on the Mediaserver successfully.

But when I try the EXACT same thing for exporting (different) directories containing all the web html files, I get an error when trying to mount on the Apache Guest machine as follows.

Failed to save mount : '/' is not a valid directory name. The available directories on 192.168.0.200 are :

/export/goserve
/export/Music
/export/TV
/export/Photos
/export/Movies
/export
/export/Music_Videos

If I redo it selecting one of the directories listed, I get basically the same message:

Failed to save mount : '/export/goserve' is not a valid directory name. The available directories on 192.168.0.200 are :

/export/goserve
/export/Music
/export/TV
/export/Photos
/export/Movies
/export
/export/Music_Videos

I have checked back and forth and as best I can tell I am doing the same thing on each of the Guests. But one mounts, and the other does not. Driving me a bit nuts.

Return to “Software - Applications and Operating Systems”

cron