Using symlinks with the NTV550

Here's the place for announcements & news
User avatar
Ian
Moderator
Posts: 751
Joined: January 1st, 2011, 8:00 am

Using symlinks with the NTV550

Postby Ian » March 16th, 2011, 12:59 am

Hi,

I've re-worked the symlinks guide to better explain how you can use them to make browsing easier on the NETGEAR NeoTV 550: Using symlinks on the NTV550

devo
Member
Member
Posts: 1
Joined: March 17th, 2011, 7:46 pm

Re: Using symlinks with the NTV550

Postby devo » March 17th, 2011, 7:54 pm

Hi Ian,

First of all, thanks for the excellent guide which is not only informative but well written and easy to follow. I was wondering why you've opted for symlinks rather than mhddfs. You say in the link above that you've explained elsewhere but I couldn't immediately spot why this was.

Thanks

User avatar
Ian
Moderator
Posts: 751
Joined: January 1st, 2011, 8:00 am

Re: Using symlinks with the NTV550

Postby Ian » March 17th, 2011, 10:09 pm

Hi there,

Thanks for your kind words about my guide. I do try hard to keep things simple and explain things clearly so it's satisfying to hear that I've achieved that, at least partially. The fact that you've highlighted a short-coming in the guide tells me I'm not quite there yet ;)

I could have sworn I'd explained it elsewhere on my site but having now consulted the page where I thought I'd explained it I haven't explained it there at all :eek: So, I'll explain it now:

By the way, if you are the author of mhddfs then this should prove a very interesting conversation and will probably highlight how totally mis-informed I am about it :lol:

I've never actually used mhddfs but when I was researching it I came across a few reports of high CPU usage, huge logs being created and several bug reports from people who were using it. Others complained that it slowed down reads which, given people will potentially be stretching their server by streaming multiple simultaneous high bitrate videos from it then I didn't think it was the solution for me.

In addition I don't believe it offers the same level of flexibility that you get with symlinks (for example the ability to exclude individual sub-folders). Combine this with the fact that mhddfs is not available on a ready-made NAS or on Windows-based systems and you'll see why I'm suggesting symlinks are a preferred solution.

But I must stress that I am by no means an expert on such things so my opinion is just my opinion.

So, are you using it? If so, how are you getting on with it?

Ian.

sirving9
Member
Member
Posts: 2
Joined: March 22nd, 2011, 6:54 pm

Re: Using symlinks with the NTV550

Postby sirving9 » March 22nd, 2011, 7:00 pm

Thanks Ian for an interesting guide.
I am having trouble making my NeoTV 550 see the moves stored on my Seagate GoFlex Home. Detail in http://forum1.netgear.com/showthread.ph ... post338653
I am pretty desperate for a Vista version of your symlink script or the NeoTV550 is being returned because it just isn't doing anything it should - will you help?
Cheers,
Stuart

User avatar
Ian
Moderator
Posts: 751
Joined: January 1st, 2011, 8:00 am

Re: Using symlinks with the NTV550

Postby Ian » March 22nd, 2011, 10:20 pm

Hi Stuart,

OK, I've read your thread on the NG forums but I'm not convinced your problem is your lack of a suitable symlink script. It looks like a "permission problem" and as such I think a symlink will just move the permission problem to another folder/drive.

On the Neo under "Select media sources" there is an "I don't see my media" option. In there you can ask the Neo to scan your network for media. When you run that option does it see your GoFlex device at all?

sirving9
Member
Member
Posts: 2
Joined: March 22nd, 2011, 6:54 pm

Re: Using symlinks with the NTV550

Postby sirving9 » May 1st, 2011, 7:55 pm

Hi Ian,

I don't know where you mean by "I don't see my media".
In "Configure your NeoTV, it eventually takes me to "Select Media Folders to be Shared": -

media1.jpg
media1.jpg (43.43 KiB) Viewed 4461 times


The folder with my .avi files on my Seagate External hard drive is not available there, even though it is available on my PC. So I "Add Folder" and I am able to navigate to the Seagate folders but it says: -

not shareable.jpg
not shareable.jpg (13.85 KiB) Viewed 4461 times


Really disappointed, I thought this was plug and play and it is treating my connected external hard drive as 'another computer'. What do you suggest?

Cheers,
Stuart

User avatar
Ian
Moderator
Posts: 751
Joined: January 1st, 2011, 8:00 am

Re: Using symlinks with the NTV550

Postby Ian » May 1st, 2011, 9:14 pm

Hi Stuart,

I was referring to the options on the Neo UI itself, not the desktop app.

Once you've selected that option on the Neo and the Neo has re-scanned your network does your Seagate drive show up?

Ian.

bruuss
Member
Member
Posts: 10
Joined: August 19th, 2011, 2:25 pm

Re: Using symlinks with the NTV550

Postby bruuss » August 19th, 2011, 3:11 pm

hi Ian,
thank you for your interesting and helpful guides, i really have found them useful, as I have recently purchased NeoTV550 ;)

I would like to ask your help though on setting up symlinks on my Qnap NAS (TS-212).
I have read your guide on the subject and most likely I will use your kindly shared file (http://www.havetheknowhow.com/scripts/C ... mlinks.txt), as I have a similar situation with many unfriendly organized folders/sources that need to be presented in a simple way on Neo.
The questions that arose, are:
1) where should i put this script file to run it; or it does not matter at all as long as it is on NAS?
2) how deep should be the path to DestFolder and SourceFolders described? since the very root folder of disk? or it depends where the script is placed?
3) can I add in the script locations on remote Win7 machine (connected to the same router as the NAS) and will the script still work (for other parts) when run with remote Win7 machine switched off?
4) can I add in the script locations on external USB hard drive (attached to NAS), how do I find it's correct path on my NAS and will the script still work (for other parts) when run with external hard disk switched off?
5) i guess, the DestFolder in my case has to be located in a specific place in order for it to be available for sharing via my NAS Administration web GUI?

I'd like to add that I am a total nooby in terms with working with Linux, just got installed Putty on my Win7 a week ago and have played around for some simple commands (some of them coincide with MS-DOS for my surprise) but not more than that.

User avatar
Ian
Moderator
Posts: 751
Joined: January 1st, 2011, 8:00 am

Re: Using symlinks with the NTV550

Postby Ian » August 28th, 2011, 10:42 am

bruuss wrote:hi Ian,
thank you for your interesting and helpful guides, i really have found them useful, as I have recently purchased NeoTV550 ;)

I would like to ask your help though on setting up symlinks on my Qnap NAS (TS-212).
I have read your guide on the subject and most likely I will use your kindly shared file (http://www.havetheknowhow.com/scripts/C ... mlinks.txt), as I have a similar situation with many unfriendly organized folders/sources that need to be presented in a simple way on Neo.
The questions that arose, are:
1) where should i put this script file to run it; or it does not matter at all as long as it is on NAS?
2) how deep should be the path to DestFolder and SourceFolders described? since the very root folder of disk? or it depends where the script is placed?
3) can I add in the script locations on remote Win7 machine (connected to the same router as the NAS) and will the script still work (for other parts) when run with remote Win7 machine switched off?
4) can I add in the script locations on external USB hard drive (attached to NAS), how do I find it's correct path on my NAS and will the script still work (for other parts) when run with external hard disk switched off?
5) i guess, the DestFolder in my case has to be located in a specific place in order for it to be available for sharing via my NAS Administration web GUI?

I'd like to add that I am a total nooby in terms with working with Linux, just got installed Putty on my Win7 a week ago and have played around for some simple commands (some of them coincide with MS-DOS for my surprise) but not more than that.


Hi Bruuss and welcome to the forum. Apologies for the delay in replying but I have been away on business.

To answer your questions (although I don’t own that particular QNAP model so my advice may be a bit off):

1). It doesn’t really matter where you put the script, the “public” directory or your “home” directory is as good a place as any.
2). The DestFolder and SourceFolders are absolute paths not relative to where the script is placed. So, specify them as you would if you were trying to “cd” into those locations from the root folder.
3). Yes as long as the script can see the Win7 machine when it's switched on obviously. My error trapping may be a bit suspect so I’m not sure how it will cope if the machine is switched off. Please let me know how you get on and I’ll look at making it a bit more robust for such circumstances if it doesn’t work nicely.
4). As 3.
5). Correct.

Please let me know how you get on. :thumbup:

Ian.

bruuss
Member
Member
Posts: 10
Joined: August 19th, 2011, 2:25 pm

Re: Using symlinks with the NTV550

Postby bruuss » August 28th, 2011, 3:56 pm

thank you Ian, I will try to implement that a little later and will let you know how it worked (or not) out ;)


Return to “Announcements & News”

cron